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Agenda

 Why we weight

 Raking weights with the SPSSINC RAKE extension command 

 Practical issues with raking

 Using rake-weighted data in statistical procedures

 Summary
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PURPOSE OF WEIGHTING
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Purposes for weighting - I

 Making a sample representative of a population for analysis

 Estimating population quantities, e.g., counts, percentages, means

 Causal modeling, e.g., regression

 Correcting sample variable distributions (categorical weighting)

 Correcting sample variable distributions (scale weighting)

 Adjusting for randomness, sampling schemes and post stratification

• Deliberate over- or under- sampling

• Stratified, clustered, multi-stage, etc

• Requires different algorithms as well as weights when calculating variances

• Random nonresponse adjustments

 Samples representing wrong population (noncoverage or overcoverage)

 convenience samples

 Reducing selection bias

4
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Purposes for weighting - II

 Statistically correcting modeling assumptions

 E. g. Heteroscedasticity of regression error terms

 Assigning importance weights to cases

 E. g., influence case weighting in TREES

 Overweight cases of particular interest, e.g., maximize retention probability of most 

profitable customers

 For computational efficiency

 A case represents n identical cases (replication weight)

 NOT good for

 Standard weighting does not address measurement or coding errors

• E. g., underreporting income from capital gains

 Missing values for respondents (item nonresponse)

• Imputation techniques address missing values

• Can adjust control totals for missing values

 Modeling may require more complex weighting schemes
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Reasons not to weight

 Complexity

 Models may already correct for selection bias

 Tobit regression

 Heckman regression

 Survival problems

• Cox regression

 Increased variance with large weights

 Unstable estimates

 Bias vs variance tradeoffs

 “Survey weighting is a mess. It is not always clear how to use weights in estimating 

anything more complicated than a simple mean or ratios, and standard errors are tricky 

even with simple weighted means….Contrary to what is assumed by many theoretical 

statisticians, survey weights are not in general equal to inverse probabilities of selection but 

are typically constructed based on a combination of probability calculations and 

nonresponse adjustments.”

 Andrew Gelman, Struggles with Survey Weighting and Regression Modeling, Statistical 

Science, 2007
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There are several types of weights

 Types of weights

 Frequency or replication weights

 Probability of selection weights

 Sample adjustment weights

 Importance weights

 Modeling weights

 All of these apply to some procedures in Statistics

 It is important to understand how a particular procedure interprets weights

 The implications are different depending on the statistic
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Complex sample designs require special procedures

 Complex Samples option 

procedures supports multistage, 

clustered or unequally sampled 

designs of many types

 If designing a survey

 Analyze > Complex Samples > 

Select a Sample

 If using an already constructed 

sample

 Analyze > Complex Samples > 

Prepare for Analysis

 Creates a plan file describing design

 Apply appropriate CS procedure 

using the plan file (Analyze > 

Complex Samples > …)

 Includes frequencies, 

descriptives, crosstabs, linear 

models, logistic regression and 

others

 CS procedures are not designed for 

poststratification weighting
8
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THE SPSSINC RAKE 

EXTENSION COMMAND
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Extension commands add functionality to IBM SPSS Statistics
 Provide standard Statistics syntax for Python, R, or Java programs

 Most IBM-created extension command names start with SPSSINC or STATS

 Recognize by menu icon 

 Work like built-in commands

 Usually include a dialog box built with the Custom Dialog Builder

 By convention,  COMMAND-NAME /HELP displays the syntax help (F1 in V23+)

 Require Python and/or R Essentials as appropriate

 Install from Utilities or Extensions menu

 Over 110 are available and the number continues to grow

 Most not tied to a particular Statistics version

 Free

 Consider using environment variables to specify where to install

 May need to install using Run As Administrator

 Sharing

 Updating to new Statistics versions

 My settings

• SPSS_CDIALOGS_PATH=C:\dlgcommon

• SPSS_EXTENSIONS_PATH=C:\extcommon; C:\extcommon18

 On Windows, environment variables are set via Control Panel > System > …
10
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In Statistics 22-23 Utilities > Extension Bundles > Download and 

Install Extension Bundles

 May require admin 

permissions

 Start Statistics using 

Run As Administrator 

(Windows) if possible
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In Statistics 24+ Extensions > Extension Hub

 Also 

available 

directly from 

website
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The appropriate weighting technique depends on the information 

you have
 Assume a 2-dimensional set of cells defined by  crossing categorical variables A and B with 

categories         and      . The cells are        .  This extends to any number of dimensions.

 If you know the joint distribution in the target population of A and B

 Weight each cell,         as                 

where N's are population counts and n's are sample counts, and K normalizes the weight 

to sum to the actual sample size

 Number of cells grows very rapidly – demands a lot of information

 Small cell counts vulnerable to sampling variability

 If you know only the marginal distributions

 Consider raking aka rim weighting (multi-dimensional poststratification) aka iterative 

proportional fitting

 Assumes probabilities and weights are function of marginals only.  No interaction

 If you have partial information about the joint distribution

 Convert joint distribution to one dimension and rake with that and the remaining marginals

 May need to further collapse categories

13
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There are other approaches to weighting besides raking

 Inverse Propensity Score

 Estimate the propensity/probability of being in the sample using sample and population 

data

 How to estimate propensity?

• E.g., regress cell counts on population counts in k dimensions

• Regression on totals (cells)

 Weight by inverse of propensity

 Need to bound weights as p -> 0

 Scale sum of weights to actual sample size

 Maximum entropy

 Use the known marginals and other information and make weights that are consistent 

with the information but are otherwise as uniform as possible (maximize entropy)

• Requires solving nonlinear constrained maximization problem

 If information is only marginal distributions, converges to raking

 If information is joint distribution, converges to joint probability weighting

14
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Raking adjusts cell counts so that marginal totals match control totals 

15

Lowercase symbols refer to the sample

Uppercase symbols refer to the population

Superscripts refer to the iteration

Originally due to W. Edwards Deming and Frederick F. Stephan,

On a Least Squares Adjustment of a Sampled Frequency Table When the Expected 

Marginal Totals are Known, Annals of Mathematical Statistics, Vol 11, Number 4, 1940

"There are situations in sampling wherein the data furnished by the sample must

be adjusted for consistency with data obtained from other sources or with deductions

from established theory."



© 2015 IBM Corporation

The iterations repeat in a raking pattern in 1 to M dimensions

 Iteration is repeated until convergence is achieved
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Raking is equivalent to fitting a loglinear model

 Loglinear models are fit by Iterative Proportional Fitting (IPF)

 Observed counts are assumed to be independent Poisson variables

 Fit by MLE using Newton-Raphson algorithm

 You can expose details of GENLOG portion of output in SPSSINC RAKE if 

necessary and adjust fitting parameters

 Don't do this for really big problems!

17



© 2015 IBM Corporation

Sample balance measured by the rim weighting efficiency

 If no input weights, this reduces to

18

 N is the total number of cases

 The square of the sum of the weights / (N * sum of squared weights)

 Equals 100 if sample is perfectly balanced

 Defines effective base

 Compares sample with a perfect random sample assuming that the 

optimal sample is proportionate

 If subgroup variances differ, this might not be optimum

 There is no magic cutoff value

cumsum(R) = N

if weights are

normalized
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Example: 1 male, 10 females balanced to 50/50

 Would you trust this sample?

 Consider estimating a mean (Std error of mean depends on variance of sum)

If w’s are equal and X’s are iid19
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Rim weighting (raking) is done using the SPSSINC RAKE extension 

command

 Data > Rake Weights or 

SPSSINC RAKE procedure

 This presentation is based on 

version 2.9.0 of the extension

 Some functionality of the 

procedure is not included in 

the dialog box

 SPSSINC RAKE is an 

extension command

20
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SPSSINC RAKE is the extension command for raking

 Requires the Advanced 

Statistics option because it 

uses GENLOG

 SPSSINC RAKE /HELP 

displays the syntax help in 

the Viewer

 Extension commands 

are not included in the 

Command Syntax 

Reference

 Might need to update 

extension.py file from 

website

 Variable names in extension 

commands are CaSe

SeNsItIvE

 Dialog box appears on the 

Data menu

21
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Raking example: one dimension: bankloan.sav  

(in …/samples/english)

 Adjust by age

 Dataset has 850 cases

 Age reported by year

 Suppose we have known 

percentages by decade of age

 Recode age using Visual Binner

 Transform > Visual Binning

22
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Recoding age with the Visual Binner (Transform > Visual Binning)

 Make Cutpoints 

can find the 

breaks

 Binner can do 

automatic labels

 Generates 

RECODE and 

metadata 

syntax.

23
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Rake to adjust proportions
Age 

Group

Age 

Code

Control 

Percent

age

< 20 1 0

20-29 2 40

30-39 3 40

40-49 4 20

50+ 5 10

24

Percentages will be normalized

(these could be counts)

Case count unchanged

You could do this without fancy

technology!

5 equations in 5 unknowns

unweighted
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Raking example: two dimensions (schoolsurvey.sav)
 High school survey

 simulated but realistic data

 4 equal grade sizes

 N of males = N of females

 2000 respondents

 Marginal control totals are known 

but not the full joint distribution

 Response rates vary by gender 

and grade

 Gender

• 60 % female

• 50 % males

 Grade

• 90 % freshman

• 80 % soph

• 70 % junior

• 60 % senior

 No response rate interaction 

between gender and grade

25

school size = 3636
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AUTORECODE converts gender to a numeric variable

 RAKE does not accept string variables

 Transform > Automatic Recode…

 Generates appropriate value labels

26
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Raking adjusts for the unit 

nonresponse

 Data > Rake Weights…

 Name a weight variable (must not 

already exist)

 For each control variable, enter 

pairs of category value and 

proportion or percentage 

 Need not add to 100

 Omitted categories get weight of 

SYSMIS

 Only numeric variables can be 

used

 Optionally scale to a fixed 

population total

 Generates SPSSINC RAKE syntax

 Up to 10 dimensions in syntax

 SPSSINC RAKE /HELP shows 

syntax chart

27
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Raking results in exact adjustment

 RAKE automatically turns 

on the calculated weight

 Six equations 

(constraints) in 8 

unknowns

 In general:

 N1 + N2 equations in

N1 * N2 unknowns

28
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Histogram shows the weight distribution

 There are only 8 distinct weights

 Sample balance is good

29
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It’s easy to see the pattern of the weights in the heatmap
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Exercise 1: Let's do one

 Using the schools dataset, schoolsurvey.sav, or, better, a dataset of your own, run a raking 

adjustment in two or more dimensions

 Make up your own control totals

 If your dataset already has a weight variable, set it on before raking

 Note that SPSSINC RAKE automatically turns on the output weight variable

 Run RAKE a second time with the weight on naming a new output weight variable but same 

control totals

 Compare the two weight variables

31
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Unweighted and weighted crosstabs – its easy to confirm the 

weights

 By default, CROSSTABS counts are rounded

32

Unweighted
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Joint distribution is different after weighting (Spearman correlations)

 The total sample size is different in the two tables

 NONPAR CORR in Help > Algorithms

 If a WEIGHT variable is specified, it is used to replicate a case as many times as indicated by 

the weight value rounded to the nearest integer. If the workspace requirements are exceeded 

and sampling has been selected, a random sample of cases is chosen for analysis using the 

algorithm described in SAMPLE.

33

Unweighted
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The weight distribution shows only eight distinct values

 Weighted case count = 

unweighted count

 This is important when 

degrees of freedom 

matter

 IQR = 1.2086 - .8122 

=.396

 Max weight = median 

wt + 1.25 * IQR

34 You will always see a decreasing pattern ->
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RAKE can take control totals from datasets

 With many categories, listing categories and values becomes impractical

 If syntax is to be reused, using dataset inputs generalizes syntax and reduces work

 Dataset and within-command specifications can be mixed

 Dataset input is not supported in the dialog box

 With many weights, turn off output of table of weights

 /OPTIONS SHOWWEIGHTS=NO

35
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Example of using datasets with emp as datasets to be weighted

36

jobcatds minorityds
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Result is the same as if control totals were specified inline

37
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Exercise 2: Study the weight distribution of your output weights

 Turn off weights first

 Frequencies on the weight

 Histogram

 Custom table of mean weight using raking variables in rows, columns, layer

38
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Raking can scale weights up to population totals

 Convenient for scaling 

tabulations

 DO NOT USE for 

inference

39
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ISSUES WITH RAKING

40
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Empty categories stay empty

 Using 

…\samples\english\employee data.sav

 There are no female custodians in this 

dataset.

 Rake proportions (hypothetical)

 jobcat .67 .10 .23

 gender: .45 .55 

 Weight distribution still achieves 

marginals

 Completely empty categories are 

ignored

41

Before

After weighting
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Consider what happens with a very small count

 Change one case to jobcat=4

 Rake proportions

 jobcat .57 .10 .23 .10

 gender: .45 .55 

 The raker meets the goal, but the 

weight is extreme

 Median: .9795

 IQR: .4494

 Max : median + 109 * IQR !

 This increases variability of results

 Solutions

 Bound the weights by iteratively 

reraking

 Collapse rare categories

• Clustering? 

42

After
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SPSSINC RAKE allows up to ten dimensions
 The higher the number of dimensions the sparser and larger is the table

 May produce more extreme weights

 May not converge

 May take a long time or run out of memory on 32-bit systems

 Ten dimensions with 4 categories each implies a weight table of size

4^10 = 1,048,576 cells

 Likely to exceed your sample size resulting in many empty cells

 Run time will depend on

 Number of dimensions

 Number of categories

 Number of cases

 How far the input data marginals are from the control totals

 A problem with 10 dimensions, each with 4 categories, total of 2000 cases, simulated data

 GENLOG ran out of memory on a 32-bit system

 Completed on a Win7 64-bit system in 1 hour

 SHOW=YES would display the GENLOG output, but in this case that includes a table with 

more than 2,000,000 cells, which triggers an error and stops the procedure unless you up 

the limit using SHOW

• But don’t!

43
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Performance statistics show the benefit of external mode
 External mode runs from a command prompt with no user interface like Statisticsb via Python

 Statisticsb is part of SPSS Statistics Server

 External mode or Statisticsb can use much less memory and time

 A job can be converted to external mode with just a few keystrokes and run from Python

 Cannot use scripting apis

 Can capture Viewer output with OMS

44
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The rake job in traditional and external mode forms

 In external mode there is no user interface, Viewer, or Data Editor present, but Viewer (spv) 

files can be produced via OMS

 Run the Python job as

 python myjob.py

 Plain text output can be captured or suppressed

 Statisticsb operates similarly but without the need for Python

45

Internal mode – syntax window External mode – run from Python

or
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Exercise 3: Run rake in external mode

 Create myjob.py in any text editor such as Notepad or using the syntax window

 Use quotes around the name when saving to force the extension to be .py

 Add SAVE command, e.g.,

 SAVE OUTFILE="c:\aarp\tendimensionsraked.sav".

 Run the Python job as

 python myjob.py

 May need path: c:\python27\python myjob.py or c:\python26\python myjob.py

 Open Statistics and examine the weight

 Set up OMS output capture and run again

46

oms /destination outfile="c:/temp/results.spv" format=spv.

<your syntax>

omsend.
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External mode can be much faster and use much less memory

 Capture Viewer output in spv format with OMS

 Viewer output by default appears as text in a 

console window, but that can be suppressed

 External mode requires Python Essentials 

 So does SPSSINC RAKE

 External mode applications can also be built 

with .NET plugin and provide a user interface

47
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Control total proportions can be nested to allow for interactions

 You may have nested proportions, e.g., minority proportions within job categories

 As jobcat and minority dimensions raking would adjust only overall proportions

 If there are interactions

 Combine the interacting dimensions into a single variable

 Express the control totals as multiplicative terms

 Requires more knowledge of the joint distribution

 In the limit this amounts to specifying the entire joint distribution

48
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Distribution before weighting shows an interaction by the IOT

49
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Raked proportions take nested structure into account

50
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Partial knowledge of the joint distribution can be used along with the 

marginal distributions
 School  example revisited

 Suppose known population information includes

 gender totals

 grade totals

 gender by grade totals

 totals of students from single parent households by grade

• But not known by gender grade

 Solution

 Compute a variable representing both gender and grade

19 = ngender = 1 and grade = 9, i.e.

female frosh

 Rake by gendergrade and singleparent using joint 

distribution of gender and grade and marginal distribution of 

singleparent

 With self-reported data, possible underreporting bias of single 

parent status (or gender or grade) is not fully resolved

 differential nonresponse is corrected assuming accurate 

status51
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Issues: control totals

 Where do these come from?

 Algorithm treats them as exact

 Use a source with little or no sampling variability such as census data

 Could use a prior identical survey to control period to period variability

• Alternative is to use the raking dimensions as controls

 Case-control matching might be useful if there is a treatment

 FUZZY extension command can select these samples

 What if some categories of a raking variable are not available for other 

variables?

 state by ethnicity

• American Indian by state

• No data on Indians except in a few states

• Combined with white elsewhere

 solution: create a nested rake dimension combining State and Ethnicity in one dimension 

using the partial knowledge approach

• Control totals can be expressed as formulas

 A nested rake dimension removes the independence assumption otherwise used

52
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Sources of control totals (Michael P. Battaglia, David Izrael, David 

C. Hoaglin, and Martin R. Frankel, AAPOR)

 Large samples or actual censuses minimize sampling error

 Census short-form data. 

 Census long-form variables, 

 Census PUMS, 

 Current Population Survey, 

 Census Bureau population projections, 

 National Health Interview Survey

 American Community Survey

 Variable definitions not always consistent or implemented in the same way

 Sources may have only partial coverage

 Rake the relevant data and use the raked weights (1 outside the initially raked cases) as 

input into the larger rakings

 Or rake each subgroup separately, aggregate and rake to known national totals

53
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Issue: missing data 

 Values of a raking variable recorded as missing for some cases (item nonresponse)

 Example: age group sometimes not reported

 Affects matching national totals

 Solution: Calculate missing percentage and subtract from total age counts

54
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Imputation of missing data in control variables

 Approaches

 Omit cases and adjust control totals

 Data > Replace Missing Values (RMV)

• Meant for time series data

 Analyze > Missing Value Analysis (MVA)

• Missing Values option

 Analyze > Multiple Imputation (MULTIPLE IMPUTATION)

• Missing Values option

 Hot deck – replace missing values with values from a similar case

• http://www.ncbi.nlm.nih.gov/pmc/articles/PMC3130338/

• No built-in command

• Use FUZZY extension command with additional processing

• FUZZY does case-control matching

• Treat pool of complete cases as the controls

• Match on selected non-missing values

• Merge values from matched cases into the target dataset

 All missing value imputation methods have assumptions that are often unverifiable

 Do sensitivity analysis to see how imputations affect results

55
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MVA – first understand the missing data

56



© 2015 IBM Corporation

MVA: Use imputation methods to fill in values – fixed values
 Listwise and pairwise report estimated statistics 

 Regression and EM methods can add random term for dispersion

 Assumptions

 MCAR – missing completely at random

• Missing pattern does not depend on the data at all –

completely random

• Assumed for listwise, pairwise, and regression

• Gives unbiased estimates of means, covariances if true

 MAR – missing at random

• Data with the same observed values have the same conditional distribution as the 

other variables

• Probability that values are missing and the values depend on observed values but 

not unobserved

• Assumed for EM method

 Difficult to validate these assumptions but Little’s MCAR tests MCAR null

 Imputation does not guarantee that realized values are actually legal or in range

 Data Validation procedure can be very helpful here

• Checks valid values and cross-variable relationships

 If missing data is substantial, check sensitivity of results to different imputation methods

57
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MULTIPLE IMPUTATION preserves the distribution

 Builds a model of missingness

 MCAR and MAR are handled

 Automatic method or customized

 Important that measurement levels are set correctly

 Uses frequency and sampling weights

 Support for range constraints and custom imputation models

 Generates multiple samples drawing randomly from the estimated missing distributions

 Uses SPLIT FILES mechanism to manage these

 Special split variable is created: Imputation_

 Don’t turn this off!

 You do not suddenly have five times as much data

 Procedures that support multiple imputation show result for each split and then merge 

results appropriately

 Procedures supporting MI including Frequencies, Descriptives, Crosstab, Means, 

Correlations, Generalized Linear Models, Regression, Binary Logistic, and others but not 

Custom Tables

 Rake first and then impute and analyze

58
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Issues: unrakeable problems

 Can't make bricks without straw – if a category doesn't occur in a sample, raking can't match 

its total

59

Before After
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Impossible problems are - impossible

 Structurally empty cells will stay that way

 Seeding empty cells when data are sparse may result in large weights and, hence larger 

variance

 Probably better to collapse categories to avoid empty cells except for structurally empty (e.g. 

pregnant males)

60
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Issues: Bounding the weights

 Sometimes raking can produce a few very large weights

 Examine histogram and quartiles of weight

 May increase sampling variability

 Bounding the weight introduces some bias but may reduce MSE

 Ad hoc rules for bounding

 5 * mean weight

 (median weight) + 6 * IQR of weight

 Algorithm

 Rake

 Truncate output weights according to bounding rule

 Rake starting with truncated weights

 Repeat until all weights within bounds or boredom sets in

 In truncation after first step use 1 + criterion

 This can take many iterations

61
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Python program run in Statistics or in external mode can bound 

weights

Part 1 - run a RAKE command in a program from the syntax window

 rakeTrimmer.sps

 Python code placed between begin program and end program

62
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Part 2 - Check the weight distribution and, if necessary, trim large 

weights and run RAKE again

63
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Part 3 – Report the outcome

 A real implementation would parameterize 

the rake specification and maximum 

iteration limit, and stabilize the count

64
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USING RAKE-WEIGHTED DATA 

IN STATISTICS PROCEDURES

65
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There are several types of weights

 Types of weights

 Frequency or replication weights

 Probability of selection weights

 Sample adjustment weights

 Importance weights

 Modeling weights

 All of these apply to some procedures in Statistics

 It is important to understand how a particular procedure interprets weights

 But the implications are different depending on the statistic

 Generally counts, means, percentages can be handled, but inferential statistics are messier

66
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SPSS procedures vary in how weights are treated

 Procedures such as Frequencies, Crosstabs, and Ctables will use fractional weights

 Most other procedures treat weight as a replication weight and round

 NPTESTS

 Some procedures ignore weights

 Degrees of freedom will be wrong in procedures such as regression if sum of weights does 

not match number of cases and weights do not represent replication

 Complex Samples procedures treat weights as representing probability of selection 

 Computations reflect sampling design

 CSCOXREG vs COXREG for survival problems

 Gentle raking could be used for post stratification

 Weight status reported in Notes table and on Data Editor status bar

67
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Regression procedure weights are different

 REGRESSION 

weights are replication 

weights represent 

actual case and are 

not rounded

 Upscaled weights 

overstate degrees of 

freedom

 Use the raked weight 

as the WLS weight to 

preserve proper 

degrees of freedom

 Estimates will match 

CSGLM but standard 

errors are not the 

same
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Output reports more degrees of freedom than there are cases if 

standard weight setting is used and weights are not normalized

 t and F d.f are 

wrong

 Coefficients are 

okay
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GLM Univariate is partially consistent

 Regular weight is rounded 

in this procedure

 Use raked weight as WLS 

weight

 Differ from CSGLM

 CSGLM estimators are 

approximately 

heteroscedastic 

consistent
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Trees influence weight is not a sampling or replication weight

 Influence weight reflects 

importance of cases

 E.g., most profitable 

customers in a churn 

model
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CROSSTABS weight options determine how fractional weights are 

treated

 " if the data file is currently weighted 

by a weight variable with fractional 

values (for example, 1.25), cell counts 

can also be fractional values. You can 

truncate or round either before or 

after calculating the cell counts or use 

fractional cell counts for both table 

display and statistical calculations."

 CROSSTABS options

 use weights as is

 round

 truncate

 round or truncate accumulated 

cell counts

 Statistics such as Chi-square are 

calculated based on the table

 Set to No adjustments to handle 

non-integer weights

 Exact Tests require integer weights
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Custom tables procedure offers choices for weight treatment

 Table without weights
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Rake to new control totals
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Weighting the sample

 Heatmap shows the distribution of the 

weights by the raking variables
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Use weight2 as effective base

 More accurate calculation of standard errors, confidence intervals, and test statistics

 Effective base is available as a cell statistic

 Replaces standard weight variable if specified
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Exploring Effective Weight

 Effective weight 

typically gives more 

accurate test 

statistics

 Still an 

approximation
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Use Utilities > Modify Table Appearance to highlight significant cells
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Requires new version of SPSSINC MODIFY TABLES extension
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Effective weight with gender example

 Data were raked to 

give 50/50 split

 Adjusted count is the 

effective base for a 

cell

 Cells are 

homogeneous here

 3.64 = 11 * .331
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IN CONCLUSION
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Summary

 Raking can adjust for nonrepresentativeness of a sample based on knowledge of only the 

marginal distributions of one or more relevant classifying variables

 This may increase variability of results, reducing bias while increasing variance

 The SPSSINC RAKE extension command constructs the weight

 SPSSINC RAKE is one of many extension commands available free from the SPSS 

Community website (http://www.ibm.com/developerworks/spssdevcentral) or new IBM 

Predictive Analytics Community (https://developer.ibm.com/predictiveanalytics/)

 Good practice is to examine the distribution of the constructed weights and consider 

adjustment of extremely large values by truncation or iteration

 External mode can conserve computing resources

 Implications of using fractional weights should be considered for each statistical procedure 

used

 Weighted/reweighted datasets can give a better picture of the population when used in 

moderation
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Questions
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My contact information

Jon Peck

jkpeck@gmail.com
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